烟雨红尘的寻觅,诗画江南的惦记

MySQL5.5数据库文件转换成兼容MySQL5.1的方法

行走江湖 2017-07-05 浏览(1203) 评论(2)
- N +

  

 WordPress博客从云服务器迁移到云虚拟主机出现的问题。   我之前一直使用MySQL5.5数据库,导出的.sql数据库文件都是只支持5.5版本MySQL数据库的,现在阿里云全民虚机MySQL版本只支持MySQL4.0、5.0、5.1,我只能选择MySQL5.1,导入5.5版本的数据库文件,怎么办?

解决方法

打开导出的.sql文件,搜索utf8mb4,全部替换成utf8,保存,再导入阿里云虚机的数据库中,就行了。 (注意:如果导入数据库文件出现错误,说明原数据库没有清空,清空后再导入即可。)

本文标题:MySQL5.5数据库文件转换成兼容MySQL5.1的方法
作者授权:除特别说明外,本文由 情醉中国风 原创编译并授权 情醉中国风博客 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
作者:情醉中国风

评论列表 (2)条评论
网友昵称:小哥哥
小哥哥游客7个月前 (02-27)回复
按照这个方法,godaddy导出5.5导入aliyun根本不行。还是老提示:您当前选择的数据库备份文件版本不被支持,系统只支持4.0,5.0和5.1版本的mysql备份文件。
网友昵称:情醉中国风
情醉中国风管理员7个月前 (02-27)回复
@小哥哥 难道我用的阿里免费虚机是以前1G版本的,所以不一样-_-||

发表评论